Matthias Andreas Benkard | 40d598d | 2021-08-17 21:13:57 +0200 | [diff] [blame] | 1 | { lib, fetchFromGitHub, installShellFiles, rustPlatform, ronn, pkg-config, libsodium }: |
| 2 | |
| 3 | rustPlatform.buildRustPackage rec { |
| 4 | pname = "bupstash"; |
| 5 | version = "0.10.2"; |
| 6 | |
| 7 | src = fetchFromGitHub { |
| 8 | owner = "andrewchambers"; |
| 9 | repo = pname; |
| 10 | rev = "v${version}"; |
| 11 | sha256 = "sha256-0PKQYvKmAGP4/15nKhB+aZh8PF9dtDFjXEuPCA5tDYk="; |
| 12 | }; |
| 13 | |
| 14 | cargoSha256 = "sha256-6zVWKVtTL6zbB4Uulq+sK4vm3qAC0B5kf0DmDv5aneo="; |
| 15 | |
| 16 | nativeBuildInputs = [ ronn pkg-config installShellFiles ]; |
| 17 | buildInputs = [ libsodium ]; |
| 18 | |
| 19 | postBuild = '' |
| 20 | RUBYOPT="-KU -E utf-8:utf-8" ronn -r doc/man/*.md |
| 21 | ''; |
| 22 | |
| 23 | postInstall = '' |
| 24 | installManPage doc/man/*.[1-9] |
| 25 | ''; |
| 26 | |
| 27 | meta = with lib; { |
| 28 | description = "Easy and efficient encrypted backups"; |
| 29 | homepage = "https://bupstash.io"; |
| 30 | license = licenses.mit; |
| 31 | platforms = platforms.unix; |
| 32 | maintainers = with maintainers; [ andrewchambers ]; |
| 33 | }; |
| 34 | } |
| 35 | |