| { lib, fetchFromGitHub, installShellFiles, rustPlatform, ronn, pkg-config, libsodium }: |
| rustPlatform.buildRustPackage rec { |
| owner = "andrewchambers"; |
| sha256 = "sha256-0PKQYvKmAGP4/15nKhB+aZh8PF9dtDFjXEuPCA5tDYk="; |
| cargoSha256 = "sha256-6zVWKVtTL6zbB4Uulq+sK4vm3qAC0B5kf0DmDv5aneo="; |
| nativeBuildInputs = [ ronn pkg-config installShellFiles ]; |
| buildInputs = [ libsodium ]; |
| RUBYOPT="-KU -E utf-8:utf-8" ronn -r doc/man/*.md |
| installManPage doc/man/*.[1-9] |
| description = "Easy and efficient encrypted backups"; |
| homepage = "https://bupstash.io"; |
| platforms = platforms.unix; |
| maintainers = with maintainers; [ andrewchambers ]; |