Nix files.

These new Nix files can be used as an alternative to the Stack-based
build.

Change-Id: I56ae4e27fa26541cd88583a7806f2834cb6a1735
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..fb53cde
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,19 @@
+# This file exists for legacy Nix installs (nix-build & nix-env)
+# https://nixos.wiki/wiki/Flakes#Using_flakes_project_from_a_legacy_Nix
+# You generally do *not* have to modify this ever.
+
+{ pkgs ? import <nixpkgs> { }, nix-gitignore ? pkgs.nix-gitignore }:
+
+(import
+  (
+    let
+      lock = builtins.fromJSON (builtins.readFile ./flake.lock);
+    in
+    fetchTarball {
+      url = "https://github.com/edolstra/flake-compat/archive/${lock.nodes.flake-compat.locked.rev}.tar.gz";
+      sha256 = lock.nodes.flake-compat.locked.narHash;
+    }
+  )
+  {
+    src = nix-gitignore.gitignoreSource [ ] ./.;
+  }).defaultNix